Moving forward on the Chimera Install...firmware issue [Uncategorized] (1)
Recommendations for 300*300 bed in Australia [Uncategorized] (5)
Failing Stepper Drivers [Troubleshooting] (10)
200x200 bed for Wilson II [Uncategorized] (9)
PICA: Reprep Full Gaphics Controller reset pins [Troubleshooting] (7)
Weird issues with auto-leveling? [Troubleshooting] (8)
Z Servo Madness [Troubleshooting] (4)
Having trouble with bottom layer [Troubleshooting] (9)
So long springy shaft couplers! ( 2 ) [Announcements / Design Updates] (25)
Dual Bowden Suggestions [Mods] (11)
Diet time! Weight reduction on the extruder - titan /w pancake stepper [Mods] (6)
Design: Fan Duct for Radial/Blower Style Fan [Mods] (7)
3 wire endstops on PICA [Assembly] (4)
Are the -1 pin assignments on the PICA board usable? [Firmware] (1)
Issues with adapting PICA firmware [SOLVED] [Firmware] (9)
Print Quality - SLOVED [Troubleshooting] (3)
Pronterface measures the bed temperature when the power is turned off but 0 degrees when turned on [Troubleshooting] (2)
Reprap wilson 2 [Troubleshooting] (3)
Missing Parts ... maybe? [Assembly] (2)
Z-axis not working [Troubleshooting] (10)
RepRapDiscount Full Graphic Smart Controller [Firmware] (17)
Y Min Endstop not being respected during auto homing sequence (solved) [Troubleshooting] (1)
Can someone slice some things in s3d for me? [Uncategorized] (4)
Print cooling fan will not turn off [Troubleshooting] (4)
Broke my glass plate for the first time, what kind of glass [Uncategorized] (4)
Banding? on layers with retraction [Troubleshooting] (3)
Trouble setting up auto-leveling in Marlin [Troubleshooting] (3)
Print Quality Issues [Troubleshooting] (10)
Geared Extruder [Mods] (1)
Stepper/lead screw combo [Uncategorized] (8)