Brief pauses during print causes zits


I finally have my printer up and running and it’s been producing some fantastic prints! My main concern right now is that my prints have little dots or zits. From what I’ve read, this is usually the result of wonky retraction settings, but I’ve noticed it happening in the middle of a straight line. It’s like the everything stops for just a split second, but long enough to cause this anomaly.

Any advice?


Are you controlling the print over USB or from SD card reader on the machine?


I thought it was a communication issue over USB so I tried from the SD card directly on the machine. Issue occurs both ways.


I’ve also been having this problem; SD or USB (PC or Octopi, also tried multiple known good usb cables) doesn’t seem to matter…

I read on the reprap forums that some folks had similar issues caused by the LCD support in marlin so on a long shot I tried reloading the firmware with the LCD disabled - no improvement.

Something I have noticed, it only seems to happen on more complicated models (eg: the 3d benchy boat model), if I do the simple thin wall calibration cubes etc, they come out without the blobs


also; I get the same random blobs with slic3r or cura


I tried Cura, Slic3r, and S3D. Same issue. And I have to agree with the part about complicated models. It doesn’t seem to occur very often at all with simple calibration prints.


In Cura I achieved some improvement, a reduction of zits, by reducing infill overlap and setting “Infill prints after perimeters.” I’ve also tried reducing retraction travel but that didn’t seem to help any.


I’ll give this a shot tonight and see if it helps! Hopefully Simplify3D uses similar names for these options.

Thanks Rockey!


Hi CJ1-

I’ve not done a detailed investigation of this brief hesitation issue (I also see it and I’m using Simplify3D). I have reason to believe the hesitation is associated with the 10 second refresh that Marty put in the Marlin code to “lift” the z-probe servo arm back into position in case it is sagging.

On mine, it does not hesitate at every 10 second interval, but it only does it in multiples of 10 seconds. It seems inconsistent in the 10 second intervals as well. Sometimes, it will do it every 10 seconds 3 or 4 times in a row and at other times it does it every 20 seconds or 30 seconds. I’ve never seen it go longer than 30 seconds. This may be a function of the model complexity, I don’t know.

Again, I’ve not had time to investigate further but it would be interesting to see if you and others have similar timing of the hesitation. My plan was to temporarily disable the 10 second servo refresh to see if it eliminated the hesitation. If it does, then I guess I might rethink whether it’s really necessary to refresh the servo every 10 seconds. Obviously, switching to his new design for the z-probe would eliminate the need for it altogether. I wonder if people using the new z-probe design are seeing this hesitation…

Just a thought.



I’m doing a print now w/the 10 second refresh disabled in the firmware and I haven’t seen a pause or blob yet…

good call Stro! Thanks!

it looks like I’ll be moving to the new Z-probe design sooner than I thought


Hi pcarrigg-

I’m glad it worked. Just out of curiosity- did the servo arm really sag without that refresh in there? It’s not clear to me why it should sag in the first place. It’s a geared servomotor so I would expect it to stay put unless a load was put on the arm. Perhaps vibration from the x-carriage motion acting on the weight of the microswitch hanging out on the end of that long lever arm?



I didn’t notice any sag w/o the refresh, but I only ran it for an hour or so after making the change. With a more intense / longer print the vibration/motion might become an issue…

From - configuration.h

// sometimes the weight of the servo arm and the shaking of he extruder causes the servo to slowly descend during printing until it 
// interferes with the print.  

I’m assuming @mjrice must have run into that problem at some point otherwise it wouldn’t be in there…

I’m going to run it like this until I get a chance to print out the new X axis setup and just make sure I can keep an eye on the arm…

– Paul


I had some time to mess with this over the weekend and, just to make sure the number of little zits decreased, I first increased the refresh time from 10 sec to 90. No sagging and many fewer zits.

Next, I disabled the refresh altogether and carefully watched a print and saw no sagging. No zits at all now.

In the end, I opted for making a little “sling” out of a garbage bag tie that I put around the servo arm after bed leveling is complete and it acts as a safety in case there is a sag; however, I’ve now completed four 4-hour prints and the arm has remained rock-solid EXCEPT one time when some static electricity from my finger to the printer frame caused it to move downward slightly.

I’ve been thinking about getting some grounding wired into this thing because the static also scrambled my LCD display a time or two. It’s really dry where I live.

I know Marty has this problem too because more than half the prints furnished in my kit have the same little zits on them…



Thanks, @stro! I’ve been collecting parts for the rack and pinion Z probe and other mods. Looking forward to resolving this artifact as well. I’m assuming the Z-arm refresh is disabled in the new firmware but I’ll check that it is before updating.


Nice job! Now that we know the cause, I’ll be upgrading to the new rack and pinion bed leveling system soon.

Thanks everybody!


Yeah, this made a huge difference!

Edit: The orange Batman was also sliced in Simplify3D while the silver one was done in Cura.


Awesome CJ1!

Yes- I have been enjoying zit-free printing since I figured out the servo refresh thing. Also- I know 3dSimplify is some $ but I can’t begin to explain the increase in quality printing from the same files formerly used in cura. Plus, everything is integrated so I don’t need pronterface anymore. Building supports is a snap. It has a couple of warts but overall it’s much better than the freeware (in my opinion).



Yes, Stro! I couldn’t agree more. I was shocked at how much better my prints were by switching to Simplify3D.


Where is the “z-arm refresh” setting In Marlin?


how do u change the the 10 second refresh for simplify 3d?