Cannot track down an under extrusion issue


new roll of PLA here from Fry’s today. Though I had some issues with it in the beginning, it took about 7x 20cm cubes printed before I found settings that worked right. I noticed it needed a little more heat than most PLA’s do (this one i started at 180, and didnt clear up until about 210)

but all of my extrusion from the bottom of the print were fine up to about half way through the print. then the troubles seem to start. there are pockmarks and gaps in the part, and i’ll attach pictures to show it, but you can see the bottom 100 layers or so are great, and then it starts to jam.

over the length of this print, i’ve noticed that there is a “grinding” noise in the extruder kind of like if you put peagravel in a sack and moved it around with your hand, which would almost always accompany the “thud thud thud” of a slipping extruder driver motor. The gravel noise is kind of new to me but the thuds arent.

here is a video on youtube showing what i’m talking about, hopefully someone here has had this issue. here are the pertinent settings from cura:

.25 layer height
wall thickness 2
infill 20% grid
printing temp 210, bed temp 70
1.75mm diameter, 100% (and then i adjust the flow on this to 87% in octoprint because it overextrudes)
retraction distance 1mm
retraction speed 150mm/sec
print speed 40mm/sec

youtube video here:


Hi…I had this problem too. Try and make sure that your extruder nozzle is mated up to the bottom of the heat break. Screw in the heat break to the heater block, Insert the nozzle and screw it up until there is a 1-2mm gap between the nozzle nut and the block, then screw the heat break down until it won’t go any further. Reassemble the hot end and heat it to working temperature. Then tighten the nozzle into the heater block a fraction. This will make sure that there is no gap between the nozzle entrance and te exit from the heat break. Of course you should make sure t is all cleaned out before you start. It sounds to me like your extruder cannot force filament out of the nozzle because it is getting blocked. The filament gets trapped in the gap between the heat break end and t nozzle and gets cooked too much, becomes to hard to shift.

Hope this helps your problem.



That actually makes a lot of sense. I’m going to have to give that a try tonight when I get home. Since I had built the printer, i’ve not had to adjust the hot end in any way. Will report back findings tonight. All this time I was dreading that I had a bad stepper motor.

The problem seems to be getting worse over the course of a few hours and only really started up when i had switched to the new roll of PLA filament. It would make sense if something was lodged down in there due to a gap in the heater block. it would extrude, but occasionally click.

This morning when I woke up it was grinding(more of a rattle) more but it was printing fine. I was able to up the temperature a little bit and slow the printer down in order to correct it which would make sense since the filament would be cooked up in there and a higher heat may help to unjam it.

I’ll report back the findings, thanks, Antonia.


did some digging into my printer today. though I did find some shards of stuff in the hot end nozzle, i couldnt see anywhere it was to jam, and the pieces in there could be attributed to a cold pullout. i’m still getting the issue but turning up the heat a little bit seems to help a little.

i also adjusted my z offset because I was getting a bit of elephant foot on my prints, and took the time to work that out.

Also went through and figured out that I need to do an 85% flow rate when using PLA. the stalling of the extruder motor doesnt seem to happen as often but does happen none the less. it’s frustrating, but i’ll keep tweaking my settings and dialing it in.

what kind of retraction settings do you guys use with this printer?


I would try lowering your retraction speed. Such a high speed can stress your extruder motor, causing eventual heat-up and skipping late in a print. I use 30-40mm/s with a distance of 2mm.


After a few days of tweaking and getting frustrated, I think i’ve got it nailed down. At least until I change filament ha!

Here are all of the things i’ve done in case someone else has this issue. One thing that I forgot to mention was that the thumping of the extruder only really happens in one area of my bed. Coincidence? maybe a glass plate that has a raised part in it?

  1. when i built the machine, I remember something about my daughter playing with the ramps board and i think she may have adjusted the extruder’s potentiometer. Getting out my multimeter I could see the x and y axis controllers were set to .880 volts, the z set to 1.2 volts (double motor) and the extruder was at .809. Adjusted it to be .890.
  2. i adjusted my z offset again. i think i was getting too much elephant foot and sticking has never really been an issue. so I let it get a little higher and now it looks a little better on that first layer.
  3. retraction… had to watch quite a number of videos on this one to figure out what was going on. the cobweb type structures set it off and the oozing on moves… I set my retraction to 60mm/sec and 5mm retraction and it seems to havve fixed it.
  4. the nozzle when i took it apart… had junk in it. pulled it all out. cleaned it, put it back in. nothign out of the ordinary. dont think it was blocked but none the less it was clear. when i put it back in my prints started to glob up, and i couldnt figure out how it was getting filament on the nozzle exterior… after watching it for a while i saw it “drip”… didnt tighten the nozzle enough, it was oozing out between the heater block and the nozzle. tightened, fixed it.

Happily printing a 12 hour boat for my son in the bath, and the only issue with it was the bow has come loose from the bed, but that’s more of a “sharp point” that just popped up. kind of makes the boat look neat anyway. cheers guys, hope this helps someone.