Esteps very different from those seen here


Hi All,
I got my Wilson II running a few weeks back, and started calibrating things.
Odd thing is, the more I calibrated the worse my prints seem to get. so I’m asking if it’s likely that I’m over extruding.

currently my esteps is set to 139 using filament that is between 1.72mm and 1.78mm
I calibrated doing runs of 100mm with my marker at 120mm and tuned till I got to within .5mm at 20.52mm

Symptoms I’m seeing are globbiness and the nozzle bumping into the print over and over. I used my google Fu and I’m fairly sure I’m over extruding.

I’ve been running my print speed between (30mm - 60mm)/s

Can someone confirm what they are using for their stock Wilson II?

Thank you.


Your symptoms sounds like over extrusion for sure.

I calibrated doing runs of 100mm with my marker at 120mm and tuned till I got to within .5mm at 20.52mm

I am a little confused about this sentence? if you put in extrude 100mm the the distance the filament needs to feed is 100mm and that’s it.

The esteps depend on a few things… what drivers you are using A4988 or DRV8825 (or others) what step mode you have selected 1/16 or 1/8 or 1/32 etc. what type of extruder and more importantly what size hob, whether it is geared or direct… all this you end up with a mathamatical number and do the test as you did.

You will find different filaments will change this significantly. I get the esteps close then I use the Tune feature to adjust for which ever filament.

I would start the print watch the first layer and keep turning the Flow down in Tune till you see it is laying a nice flat run with out extra filament sort of spewing out the side. If you keep going you will see gaps appear so then you know you are under extruding.

Note the number and start a new print with that number set as the Flow and see how you go.

To watch the printing I use a cheap “Helping Hand” magnifying glass for soldering you see on ebay with a LED light in them… with this I can see the flow of the filament very easily making this process less a guess.


Hi anth0ny,
Thanks for the reply but this has all been a tragic problem magnified by myself. Here’s the general run down.
This is a standard Wilson II printer received about 3 weeks ago. It’s got the standard direct drive etc.

Once I got the machine working, I started going through the steps of calibration. My filament was standard PLA, I measured it 5 different places and it trued out at 1.74mm
I got to the extrusion calibration and kept missing by between 30 and 40 mm short. So I cranked up the esteps till I could consistently get 100mm … many prints went by just fine even though my esteps was sitting at 139 / mm. What did I know I was making prints that didn’t look bad and life was pretty fine.

All the micro step switches were in the position they were set in from Marty. I didn’t know enough to touch them. I changed out filament and tried printing out a part I’d designed for a friend. And the dimensions were off and the thing looked over extruded.

I checked the extrusion and it was somehow short again. I started to think I might have the wrong microsteps so I pulled off the A4988 driver and looked and it was sitting with all switches in the on position. like every other driver.

When I put the driver back in I got no extrusion when I tried to check it again, and doubt ran through me, the position I put the driver in seemed right but the silk mask put the board being 1 pin higher than the rest of the drivers. I should have sought reference. I should have looked at it good before I took it out. But I was in a rush and went eh maybe I missed. So I put it in 1 pin higher … right where the mask said E0 here (more or less.) Powered it on and let the good times roll, the magic smoke was everywhere.

So there’s a good lesson, never fuss with a 3D printer unless you’re 100% certain. As it turns out the reason I had no motion when I tired it before was because the extruder stepper motor connecter had come off the Pica board.

As best as I can tell I have fried 3 drivers, the Mega 2560 and possibly the Pica board.
Add insult to injury, in my analysis and testing aka Autopsy I reset the esteps to 104 and the thing heats up and extrudes exactly 100mm or 50mm or whatever I want mm. :slight_smile:

I have a Pica on order and a new Mega 2560 and I may be able to get my hands on a few drivers and/or a Ramps board.
I’m wary of putting in a ramps board because I know that means I have to fuss with the firmware again.

So I may suffer no printing till I get all the pieces and put my printer back in order.

I do not know why I was under extruding and needed to crank up the esteps so high. And I don’t know why suddenly I’m flooding my build platform with plastic… but It all has been educational and I’ll take my lumps. I probably had it too easy putting together the Wilson II. It went together like it was designed to.

Thanks again.


We are all here to learn and sometimes it bits. As far the the using Ramps 1.4 this is a good thing to learn with… if of course you want to learn… for $50AUS there are complete sets of Arduino + ramps 1.4 plus 5 DRV8825 drivers on ebay. If you want to tinker get this and if you bugger it that’s pretty cheap.

Marty’s PICA is way better but it is expensive to “learn” on… I have mine sitting in the cupboard waiting for the latest Marlin/Marty 1.1 release is sorted and rock solid then I will install it… probably never touch it again.

If you do get a Ramps 1.4 there are 2 things I do to stop having problems. On the End stop pins I glue a empty row of 6x1 plug on the “+” row to stop accidentally shorting that out. The other main thing I do is de solder the 2 Power in Green plugs off the board and solder in 2 + and 2 - leads and put plugs on them or go direct to the power supply. This is a known issue with those plugs burning because of bad contact.


Really good information. I will keep an eye out for it, a Maker friend gave me a ramps so I might try some experimenting.
But right now I’m really happy with the Pica board and have a spare on the way.
The extra pins have my mind reeling on what can be done.

I still have a long way to go and this hobby has provided me with a great deal of joy.
Best wishes to everyone.

Oops meant this to be a reply to Anth0ny.

By the by, my printer is alive and well again. The same person who gifted me the RAMPS gave me the drivers too .
Which was important as my bumble blew all 4 drivers


And I’m back. Hi All.

So after resurrecting my printer. I got it working pretty darn well.
I printed out some fairly ok - nice prints. Then I printed Benchy which did the best I’ve ever done, but still showed signs of over extrusion. And possibly too much heat.

Per Anth0ny I took several actions to make sure I was feeding as close to the right amount as possible.

my slicer software was setup to print the first layer at 0.35mm And I was spot on with 0.35mm
This all before printing benchy.
I printed single shell cylinders and they were within 0.02 of what the gcode said the thickness should be.

The default Estep is 105 and I knocked it down to 104.
I did the extrude test again and I missed by 10mm under extruding tonight.
So I checked everything I could. the pla was rated for 235 I had the hotend a 235
my hotend is staying within 3 degrees while it is extruding.

Over and over I checked and tweaked geting up to 107 for esteps
at 107.5 I over extruded by 3mm
I backed it down a few 10ths and I under extruded by 50 on the next run.

So I figured maybe it has something to do with tension on the extruder spring.
I think I remember Marty saying he’ll tell you how to set the spring tension on the extruder later but I didn’t see how it was to be done.

All this trouble with extruding I am truly puzzled.

Looking back at things, it almost seems like there’s a chance my nozzle got clogged and that was why I was printing alright with Esteps at 139. If memory serves tried doing a cold pull to test out the procedure and that might be when things started over extruding badly.

So maybe this is the same situation again.
I have to argue gently with Anthony on his first reply. Since I was just asking what are some numbers people use in general for the Esteps to confirm that I was in the ballpark or way over. He suggested that dynamically changing the flow rate was how he made sure he wasn’t over extruding. It seems to me that if the setting is right, and the current is right for the stepper (I’m hearing no missed steps or grinding.) and the tension is set right. I should get 100mm

So that’s what I’m going to shoot for.
Thank you all for any suggestions you may have.



I didn’t give you an answer to such an open question because you didn’t mention what board you are using, what drivers you have installed, what extruder you are using and what filament you are using.

To say you are using a “stock Wilson II” means nothing to a majority of people here, less to the rest that only bought a plastic kit from Marty then bought their own electronics and even less to the rest that built their own from scratch.


Ok Anthony, Clearly I asked a complicated question with a total lack of information, that a simple answer would not suffice.

I am very sorry if I made you feel like your information and assistance was inadequate.
Please accept my humble apologies.



On Another front sports fans I have found the problem (to an extent)

I was using Octoprint to advance the extruder 100mm using the Extrude button after typing in 100mm.

This Issues the following gcode:

G1 E100 F300

For a great number of reasons (mostly frustration.) I decided to try to move extruder 30mm with the panel…
While it extruded slowly, it went to exactly 30mm.
I did this 8 times with the same result including 2 retractions when I over shot by a mm.
Then I dialed up 100mm and got 100mm exactly.
again it extruded very very slowly but that was the clue to where I should look next.

I issued another extrude 100 from Octoprint and jumped to the terminal window to see what the gcode was.

This is where I saw the F300

So I tried issuing the same code from the terminal but cut the F300 to F100 and Perfect hit every time.
I thought somehow it was skipping steps which is hard to tell at 16th microsteps

I tried adjusting the stepping current about 100mv either way and it didn’t make a difference.

F150 under extrudes a small amount, but F200 under extrudes by almost 3 times the F150
And at F300 it’s nearly 30%
I don’t know if this is an compensation routine or a problem with my hardware.

But all the time I’ve been chasing this dragon, it was because I was extruding too fast according to something. :slight_smile:

If you have any ideas please let me know.

By the way, All Power supplies are spot on.
This is all original equipment that comes in the full Wilson II kit, the one I purchased at the beginning of the month.
I had to replace the Mega 2560, and I’m using A4988 boards though 3 are not the same that came with the kit,

I love troubleshooting but I hate chasing dragons

Have a great day.

I’m tired.


I may have found the setting in the Marlin configuration_adv.h file thanks to a video from youtube.

From Tom’s explaination and my visual inspection. This seems to be my dragon. err the compensation function I was talking about.

It is enabled in Marty’s firmware but the filament diameter is set for 2.85 instead of 1.75
this is also where steps per mm seems to be used too.

Would anyone care to comment on this please?

I’ll try fiddling with it tonight when I get home.

Thanks again everyone.



Could you screenshot your extruder settings in your slicer?

If you’re extruding the right length when using the printer control, it’s definitely a slicer issue.


Hi AndreQ,
usng version 1.2.9 of Slic3r,

Thank you for the response.



Everything look’s fine in there…

I’ll try to re-read the thread when I have some more time, but you can check those in the mean time :

  • Extruder driver jumpers, are they all in there for micro stepping.
  • E-step : should be similar to the default one if you’re using the same motors :S.
  • Config : try the default one for Wilson?
  • Slicer : Again, if you can find a pre-made config, try that


Also, verify you have a .4 nozzle. Some kits came with a .5 nozzle.


it said 0.4 on the nozzle nut face


Do you normally run PLA at 235°C? I have run three different brands of PLA and they all printed very nicely at 195°C. Are you possibly over-heating the plastic?


I do not run anything normally. This is my first printer, The MakerGeek PLA I’m using is labeled as 235c And that is what I’m using as my guide.

Several problems however seem to suggest I should use something more in the 200 - 210 possibly. But I honestly don’t know how hot my hotend is getting. I don’t know how accurate the E3D V6 light thermistor is. I have a non contact thermometer that puts it between 10 and 15 degrees if what I see on the display panel. But since the aluminum block is shiny, the reading can certainly be off.

I have tried presenting just the brass of the hotend nozzle to it, and this is where I get the highest reading but otherwise it’s all a guess.

I appreciate your inquiry.


A Maker friend very experienced with 3D printers says my tension screws on the extruder should be finger tight, I know I have it much tighter than finger tight by about 4 turns using the allen wrench.

I’ll try to find answers for this as well.



When I first assembled my Wilson II, I ran Marty’s test file at five degree intervals from 220°C down to 185°C and for me 195°C was the sweet spot. At the higher temperature, I found more ‘blobbing’.


As hard as it may seem to be believed. The changing of the code in the configuration_adv.h did fix my problem.
at F100, F150, F200 I have 100mm extrusion. At F300 I miss by only 3 mm of under extrusion, which is close enough I can fix with a touch if I need but at the feed rates one expects while printing. this should never be a problem except during the greatest of bridging spans.

to be clear this was my change.
This is from Marty Rice’s Working Firmware that had to be built on Arduino IDE 1.6.8

#ifdef ADVANCE


#define D_FILAMENT 2.85
#define STEPS_MM_E 836
#define EXTRUSION_AREA (0.25 * D_FILAMENT * D_FILAMENT * 3.14159)
#define STEPS_PER_CUBIC_MM_E (axis_steps_per_unit[E_AXIS]/ EXTRUSION_AREA)

#endif // ADVANCE

#ifdef ADVANCE

#define D_FILAMENT 1.74
#define STEPS_MM_E 836
#define EXTRUSION_AREA (0.25 * D_FILAMENT * D_FILAMENT * 3.14159)
#define STEPS_PER_CUBIC_MM_E (axis_steps_per_unit[E_AXIS]/ EXTRUSION_AREA)
#endif // ADVANCE

That fixed my under extrusion at speed.
I’ll test how well it works and get back to you.

Thanks for all the replies.