Extruder extruds 4 times more than G-code command


I put together the printer and started to do some testing. I can print the test included (even if I had to use a different SD card as the one included could only be read by computer). It prints ok even if it not smooth.
I started to calibrate a few things and when I came to the extruder feed rate I meassured that I get 4-5 times more feed than commanded (checked both with LCD and with g-code directly). The steps per mm is on default 109 and I did not adjust as the difference is massive.
Checked stepper motor controller DIP switch on controller (PICA shield) and they are all on for the extruder, same as for X,Y and Z.
Have anyone had the same issue? Thinking of a short somewhere on the board giving wrong stepping.


Did some more investigation and is was not a short but a faulty DIP switch under the stepper controller for the extruder (E0). The middle switch never closed so the stepper was set to HLH which I think is invalid. Soldered a wire on top and now it works as it should.
So issue is SOLVED