First time powering own, motors jittery. (video) SOLVED

#1 Im using the kit from mjrice from tindie. This one of my first times turning on the printer and I am trying to configure and test it according to the assembly videos. The motors seem to have trouble moving. I have never done anything like this, I would greatly appreciate some help.

Edit: In case anyone else with no knowledge like me has this problems what solved it for was adjusting the screws on the stepper motor drivers (vref) as well as adjusting the output on the powersupply.


Not sure if Marty set the Vref on the drivers.They may need to be set.

Have a look at this trouble shooting post for some tips and links to how to

Check the cables are plugged in securely.

For the Z going the wrong way swap the 2 plugs around… in the video the plugs have the red wire to the top change it to the blue wire is now at the top. This will change the motor direction.

The Extruder motor wont run unless the hotend is at least heated to above 170degC. Make sure your fan is running on the hotend before you heat up the hotend.

Check all your endstop wires are in the right spots on the board and secure.


In the prepare menu select Disable steppers then manually move the bed and the extruder carriage around. Do they move freely, with little resistance?

Have you had a chance to measure output from you power supply with a volt meter? Should be 12 volts, there’s an adjustment pot if it’s low.

Edit: I see the post is marked solved, what did the trick for you?


For me what solved it was adjusting the vref on the drivers as well as changing the output on the power supply which you suggested. A bit late but thank you for your help.