[FIXED] Auto Bed Leveling suddenly stopped working - Video, Need help


Here’s a video of how it’s acting now:

It used to move up the z axis, move left on x, extend the probe, move to the middle and click the endstop.

Now after it extends the probe it moves right on the x axis, retracts the probe and then plows into the build platform. At that point I have to turn off the printer.

It used to work like marty’s sequence:

I’m not sure exactly what I did. I remember that after the last print, the probe got stuck on the build platform binder clips and then after that, the z-axis starting position seemed too high so then I tried to adjust the z-axis offset by 2mm and then this was when I started noticing the problem. Any ideas?



Is it registering the switch on the probe? It looks like it doesn’t know it hit.


I’ve had similar issues with my printer. Some things you might want to check are:
-Stepper Drivers - sometimes they go bad
-Firmware - I’ve had the bed leveling routine get screwed up but then I reflashed it and it fixed it.

I’m also having issues with the z depth. my printer went crazy and crashed into the bed, and now it is registering too high. I’ve tried all the suggested methods to adjust for this but none have worked. What I had to do as a band aid fix is disable the MIN_SOFTWARE_ENDSTOPS in the firmware and add a z offset in the gcode.


From what I can see it might registering the Z hit but the metal arm is bent or mishaped and touches the bed well before the micro switch button is pressed… so it’s pushing down on the glass before it can trigger. So it’ regeresting the bed after it pushes it down a MM or so.

Remove the metal arm so the button is the lowest part then do the Z offset calibration.

I actually ran my Wilson from the first bulldog clip strike without a metal arm.


It does register the z endstop. What’s supposed to happen before I have to turn it off is move to the middle of the platform, and take and endstop measurement there. Instead it travels the entirety of the x axis, engages the rack and pinion and then retracts the extended z endstop. That’s the new behavior. It’s as if it thinks the x axis is twice the size or it e steps are off? I wonder if a while back, I changed e steps for the x axis through gcode console in pronterface and saved to eeprom. Then when I tried updating the z axis offset using the LCD encoder, the esteps in the menu were set differently by default and then overwrote settings I made from gcode console previously? When I flash the new version of Marlin that Marty has up, my LCD is blank. Maybe LCD isn’t enabled by default.

Also thank you to such a helpful community even though Wilson I has been out for a while!


Yes could be a logical answer but you still have the issue of the micro switch arm is pushing the bed down before the switch is activated or is his a known issue and not what you are concerned about… left as it is you will be getting very inconstant z offset I would say.


The switch isn’t activating because it is being retracted from pushing to rack and pinion. It’s not that it’s pressing the switch and then the switch isn’t responding. The switch is literally pointing to the right and not downward. When I press the switch with my finger during this process, the switch responds as if it touched the build plate. For some reason the print head is moving all the way to the right and retracting the switch before it can take its first measurement of the build plate. Maybe I’ll do a better close up video.


from watching the video it looks to me like it thinks the far right position is the normal center of the plate home position. when it gets to that point what is it showing as its x location? might be as simple as reflashing the firmware, it might have gone stupid somehow. what did you change the e steps to for the x, and why? might be that its currently set wrong.


crap sorry I was looking at the second video thinking this was part of the issue… sorry… well it is an issue but not yours.

I have seen this but it’s been a while since I had a Wilson with a retractable Z and I can’t think of how I fixed it… most likely just re flashed the firmware as has been mentioned.


This solved a problem I was having with the print first layer starting too high.



reflashing firmware didn’t work. I send a M502 code to the printer to reset the eeprom and M500 to save the settings and that fixed it.