Hi I'm Antonia, from the UK, need help with something please


Hi Everybody
My name is Antonia, I have just finished building the Wilson 2, along the same lines as shown in the original videos. Whilst I am very confident in my electronics and mechanical skills. I am the worlds worst at anything software/code related.
I am about ready to install the firmware onto my Arduino Mega 2560 with a standard Ramps board. I am also using the Servo as shown in the original video’s.

I have downloaded the Marlin Zip file from the Git hub site belonging the mjrice.
My question is, Will this be the correct firmware for building the standard Wilson 2?
Do I need to make any alterations to it in order for it to function correctly upon switch on?
I don’t want to be fault finding electronics and firmware at the same tie as I won’t now which has the problem.
Any advice would be gratefully appreciated.



I’m sorry to not be of great help, because i cant recall everything, but I can give you a few tips. Read through configuration.h and change things were you seem fit. Look for:

  • Display type
  • Wilson type --> enable Wilson II
  • Servo --> enable servo and make sure its it is attached to the right pins (retract probe in auto bed leveling on your display). If it does not work, turn of the machine and change where the servo is attached (one down in the row)

When you upload the sketch with the arduino software make sure the com is correct and you have selected arduino mega as board. Good luck!


Thank you so much for replying but I did those things and it still does not work :frowning:



Hi @Antonia, you will need to comment out the line


in order to compile in the servo controls. Did you do that? It is around line 42 in configuration.h


Hi, and thanks for the help. Yes I thought it would be that. But, when I commented out the line and tried to compile. It comes up with an unknown motherboard error comment. Comment the line back in and it uploads perfectly. Weird !
Your version of Marlin now works on my system the ok apart from the servo.
Oh and my extruder wont work, ( it works when plugged into the x driver) and changing the value of the trim preset has no effect ( yes I did a pla preheat first). I swapped out the stepper shield but t still wont work. I’m going the change the ramps board next to see if its that.

As for the servo, any other idea as to why it wont compile when I do as you suggest?

Kind regards



Problem solved. My Ramps board was faulty. Swapped it out and now the extruder works fine. As for the servo problem, well that was a firmware change I had to make following the advice given only in the video of the servo upgrade given for the Willson TS. Of course that was much clearer than the Wilson 2 video on firmware. If I had watched the Wilson TS videos before I made mine it would have helped a lot.
If I comment out the line #define MJRICE_BEDLEVELING_RACK
It don’t compile at all.
Now why is that? I don’t care :slight_smile: Now to get printing!