Lost initial x, y, z pos settings?


Somehow I’ve lost my startup X, Y, and Z values. When I power up the Wilson II, all
three values are 0. That’s just wrong. What have I done and how can I fix it??


On mine those are 0 on power up untill auto home is run.


Uh Oh! When I run Auto Home the print head moves up about 10-20mm
then moves to the left side to lower the bed sensing microswitch. It then moves all the way to the right causing the microswitch to retract (yes, the X-Stop value is set to 200) but that is apparently ignored. It then starts to lower to “sense” the bed but since the microswitch was retracted it would not stop and would crash the bed and most likely break the glass …so I have to power it off to stop its descent. Any thoughts as to what is going on…i.e why does it go all they way to the right and retract the microswitch??


The auto home is supposed to move to the X end stop, which sets the X0 home and deploys the Z probe, then move the Y end stop to set Y0, then depending on the firmware version may or may not do another move to X0 to ensure the Z probe is deployed, then it moves to the middle of the X axis and probes the bed to find Z0, finally it moves to X_MAX to retract the probe.

It’s good that it moves up about 10-20 before moving to the left side, that’s all in order. I don’t know why it’s moving all the way to the X200 and retracting the probe, that shouldn’t happen and I’m thinking of a few cases were it could. Just to check assumptions, are you building a kit from Marty or have you sourced your own parts?


It is a kit from Marty. Have had it for about 9 mos now and it has been working just fine. At the time it seemed to go south I had just changed the Z-axis offset to fix a first layer print issue and selected “Store Memory” on the LCD panel. I’m thinking I might need to reload the firmware but I can’t figure out what the “current” load is. (There are two github packages - “Marlin-RC” and “Marlin-RCBugFix”) I hesitate doing this out of fear I may make the Wilson a vegetable. At least in its current condition I can do some functions. Can you tell me what the “Restore Failsafe” and “Set Home Offsets” functions do?


I sounds like there’s a broken wire or disconnected wire on your Y-End Stop switch. It’s supposed to home Y after hitting the X-End Stop and dropping the bed probe. But if your Y end stop is disconnected, it will be read as Y is all the way to zero, and Marlin won’t let Y axis move, so it goes right on, skipping the Y Home part of AutoHome. If this is the case, your LCD screen should say Y HIT at startup. If so, fix it. If not check your Y switch by clicking it by hand and it should say Y HIT within a second or so.


I’ve checked all three stop switches. They all function as expected and display “Hit” when manually actuated. I have “wiggled” the wires (don’t know the technical term for checking wires) and they all seem to be in good condition… The behavior of the extruder when I select Auto Home from the panel follows. The initial state of things before executing Auto Home are the extruder is centered over the bed and sits about 60-80mm over the bed. The bed is centered under the extruder in the Y direction. The bed-leveling probe is extracted. On execution:

  1. The extruder moves towards the X-Stop,
  2. The probe is extended when the rack hits the left carriage,
  3. The bed moves towards the Y-Stop… at the same time the extruder begins to move away
    from the X-Stop towards the right carriage,
  4. The bed hits the Y-Stop and begins to move away from the Y-Stop. The bed stops
    after moving a little more than 200mm,
  5. The extruder continues to move towards the right carriage until the rack hits the
    carriage and retracts the probe. (It does NOT crash into the right carriage). Once
    the probe retracts, the extruder then begins to move towards the bed.
  6. When it is apparent the extruder is going to crash into the bed, I turn the power off.

On one occasion, when the extruder hit the right carriage and retracted the probe
I manually operated the probe switch. The extruder stopped, rose a bit, and then
started descending and a slower rate (just as if it would do if it were doing a bed
leveling - which it wasn’t… it was still trying to Auto Home) - anyway after manually
operating the probe switch again, the extruder then tried to continue its move to the
right. Since it was already sitting as far as it could go to the right, the stepper just
growled as attempted to spin through the cog-belt.