Machine not powering on after bed levelling collision [SOLVED: Fuse Blown]


Today is the first day in a long time that I’ve fired up my wilson II, but I wasn’t paying attention and something went horribly wrong. During the bed leveling procedure, my y stepper was unplugged and the hot end came down directly on the wires that attach to the heated bed. When I looked up, the machine was not running and has not turned on since.

It looks as though the nozzle melted through insulation of the red wire of the bed thermistor and only partially severed the wire (there is still a connection). I don’t know what about this would cause the machine to stop working, but I am worried that I accidentally damaged some part of the circuitry. It looks possible that the red bed thermistor wire or the hotend could have come in contact with the metal pads that are connected to the power supply wires of the heated bed? Would this cause an issue?

If anyone has any suggestions of what may be wrong, or could tell me what to check, please let me know! I have access to a multimeter that I can use to troubleshoot. I am just getting very anxious that I fried either the power supply or the arduino board…

UPDATE: The fuse on the PICA board is blown, but the power supply still outputs 12V. I had to order the replacement fuse online, but I hope I did not damage the PICA board. I’ll update you on Friday!


I’ve installed the new fuse and everything seems to be working fine. I think that when the X-carriage crashed into the bed, it tried to keep going and the stepper motors starting pulling enough current to blow the fuse. I feel stupid for not having immediately realized this, but I don’t know much about electronics and got scared haha.

If anyone finds themselves needing replacement fuses, here’s the link to the overpriced fuses I purchased.