Motors stall on first powerup


well i’ve sourced my own parts and finally got everything together and I noticed that when I try to jog each axis that the motors only want to move in 1 direction and if I try to jog 10mm it will just stall both directions.
I am using a pica board, had to look up motor wiring and im confident that they are wired correctly now (red,blue,green,black). for the chance I got a bad batch of motors i tried connecting a spare motor off a printer at work and that didn’t act right either. I tried adjusting the pot on the motor driver, and it didn’t seem to help
anyone have any ideas what to check next?
I’m using firmware I found labeled "MarlinWilsonDefunct-master"
I’m also starting to suspect the drivers since they came from china and were cheap


Hi Andru,
The only things that come to mind is the wiring to the motor. the phase relationship is important, swapping black for green, etc might make the difference. Be sure all your voltages are right. The stepper driver needs a solid 5V supply to accurately manage the current.
Have you tried taking out all the driver chips except 1, say for the Y axis? If that does or doesn’t work, move on to the next Axis, a different driver board, pull out the Y driver so you’re only going one axis at a time.



so my issue was the dip switches under the motor drivers


Wooot for you. Glad you got it sorted.