PICA: Reprep Full Gaphics Controller reset pins


I have a new PICA board (I think it was Rev. E on the board) and I can’t get the reset button working.

I’ve got the Reprep Full Gaphics Controller setup and working using the instructions in other threads, but I can’t seem to get the reset / panic button to work. It worked fine on a previous board, so I don’t think it’s the full graphics controller having issues. This happens with Marlin 1.1.2 as well as the old firmware.

Anyone have any idea? It seems like it could be something in a config file that I missed.


It seems this might be an odd one. Can anyone confirm if their reset button works at least? If it should work, I’ll keep digging. Otherwise I might just pick up a different board since a panic button is pretty important.


I cant help with the PICA but on the Ramps it seems to change from version to version of firmware.

Also I have 2 printers in front of me both with Full Graphics and both marlin 1.1.3. One a Ramps and one a MKS Gen 1.4… the Ramps gives me a Halt message saying to reset and the MKS does a full reset as you would expect.

So yes most likely not your hardware, it is more likely pin assignments… Marty might be able to tell you which pins to assign to make it work… or there could be some code that needs a tweak.


Thanks, that is helpful. I did start with an MKS base 1.5 and it worked, so I’ll start reviewing and comparing the pins files for those.


I’ve noticed in the Pins file that the Kill pin is disabled (set to -1), even though it looks like its mapped to pin 41 in the PICA’s schematics.

you should be able to change it from -1 to 41 and have it work. I’ll give it a try tonight.


That alone didn’t get it to work… I feel like there’s a pin assignment somewhere else that we’re missing…


Thanks for looking into it. I figured it was just a pin issue. Knowing where to look is a good start!