RepRap Discount Smart Controller display all squares


I’ve heard it reported by others on this forum and it’s finally happened to me too. After connecting the Mega/PICA to a Raspberry Pi Zero W, attempting a print and abruptly powering off the printer, the display is no longer responsive.

I have a spare Mega/RAMPS around so I hooked the display up to that and same deal, display shows lines of blocks and doesn’t respond.

Bummer. Have another ordered and will remove the USB power fuse from my mega in an attempt to prevent this from happening again.


On of 2 things either the contrast needs to be adjusted or when you flashed it you used the wrong arduino board type


I’ve ran the contrast from min to max and you only get boxes or nothing. It’s pictured at max contrast. Neither of the controllers that I’ve tested with have been recently flashed. The Mega/PICA has been in service for weeks and the display was working fine. The Mega/RAMPS had been in service for almost a year since it was last flashed. There were no problems with the display on either controller until I caused whatever fault I did last night.

I suspect something was ruined in the display driver or supporting components when power was abruptly changed from the printer PSU to the 5v from the Raspberry PI or maybe it occurred when I turned the printer PSU back on. In either case, this seems to happen to Smart Controller displays when the Mega is connected via USB power and 12v power from the PSU so I’m going to remove USB power from the equation. I’ve been meaning to do this anyways, I don’t like the controller being on when the printer is off, I want it to be exclusively powered by the PSU.


Replacement RepRap Discount Smart Controller arrived and works with both the Mega/RAMPS and the Mega/PICA that I tested the other failed one with. The new one even works with the old ribbon cables which are a common fault. I think it’s conclusive. I damaged that RepRap Discount Smart Controller some how.

Wilson ready.


Did you look at the controller sideways? chuckle

Glad everything worked out and you got it going. I ran my printer a few days without my controller and while doable, it was irksome+.