Upgrade Wilson fork to Marlin 1.1?


#41

@robbforce I haven’t tested out your configuration yet as i was already working on modifying @mjrice setup so it works with my printer setup. But i did notice a couple issues.

  • When running the homing from G28 the printer will extend the probe by hitting X0 (Z-RACK) then go to the center and do it again (never retracting, just going back to X0)

  • If the Z is less anything less then the height of the probe extended it will just crash into the bed. So the process goes:

Travel Left (X0)
Travel Right (X105)
Lift Z by # …

Instead of :

Lift Z by #
Travel Left (X0)
Travel Right (X105)

  • Even with the following encoder settings it seems to really be jumpy, the original firmware didn’t seem to have this problem i could make 1 click, move my axis by 1, not 4… I might be looking at it wrong as well

// ENCODER SETTINGS
//
// This option overrides the default number of encoder pulses needed to
// produce one step. Should be increased for high-resolution encoders.
//
#define ENCODER_PULSES_PER_STEP 1

//
// Use this option to override the number of step signals required to
// move between next/prev menu items.
//
#define ENCODER_STEPS_PER_MENU_ITEM 4


#42

The Z_SAFE_HOME variable prevents this I think. It wasn’t on by default, but I enabled it in my config.

Antony mentioned a fix for this a while ago and I applied it in my config already.


#43

Re the encoder settings yes sorry that was with a 12864 Full Graphic LCD Display Smart Controller not the smaller default Wilson 2 LCD


#44

@ant0ny Thanks I put the old firmware back on just to get a couple prints done. I’ll have to take a look at it again this weekend when i get time and mess with it some more!

@robbforce Z_SAFE_HOME is enabled it’s the Z_HOMING_HEIGHT that needs to be uncommented; i did a quick compare between yours and mine and saw i completely missed that setting. Thanks!


#45

I was running the RCBugFix branch of Marlin and recently some changes seem to have broken the z offset, I suppose. Either the nozzle never reaches the bed when starting a print or I’ve had it try to descend below the bed and had to quickly turn it off. So, going back to the RC branch has restored printing for me. I created two Wilson branches on my Marlin fork: Wilson-RC and Wilson-RCBugFix, each based on the matching original branches, for anyone interested.


#46

With the release of Marlin 1.1.0, I merged all the Wilson changes onto a new branch labeled “Wilson-1.1.x”, which you can pull from here https://github.com/robbforce/Marlin/tree/Wilson-1.1.x


#47

I upgraded to the latest version from robbforce. Everything seems to work fine except when I run the bed leveling. The z sensor knocked off the rear bed clips and on the last probe the sensor was slightly tilted cause the rack contacted the end. The bed leveling routine goes too far to the extremes of travel. How do you reduce the dimensions that it probes?


#48

I’ve been wanting to try this branch out for a while just for some the updated filament change code and such.

Anyway to back up the old binary off the controller in case I hate it?


#49

I solved this problem by using the fork from mrice mentioned above.
I just set:
#define ENCODER_PULSES_PER_STEP 4
and
#define ENCODER_STEPS_PER_MENU_ITEM 1
also as mentioned above.
Everything is working fine now.


#50

After checking more things out with the fork from mrice, I found that the bed leveling worked but now I have a problem where the hot end won’t heat up, it just throws an error and pauses the printer. There were several options that needed to be changed to get the motors turning in the right direction and the PID control was commented out so that has to be enabled also. I haven’t been able to figure out the hot end heat up failure so I ended up going with the fork from robbforce and adjusting the bed leveling coordinates.


#51

I am running into a weird issue. I upgraded to the 1.1 firmware version and ironed out the issues I had with bed leveling that I mentioned above. Now when I go to print, on the first time I try to print, it does bed leveling and then when it starts printing the nozzle gets very close to the bed,to the point it is rubbing it and the extruder motor can’t push out filament because of this. If I stop the print, then go and reprint the same thing, the nozzle offset from the bed is appropriate and the print works just fine. Any ideas on what might be causing this?


#52

Adjust the z-offset. I don’t have access to mine at the moment but I believe it’s under the Control > Motion menu.

The smaller the number, the closer it is. (for example, I think the default is -11, -12 would be closer to the bed, -10 would be farther away. On mine, I have to take it to about -10.25)

Hope that helps. That’s really the only problem I encountered other than needing to configure for full graphics LCD controller.


#53

I have been seeing similar, but have assumed it was a mechanical problem.

I’ll look through the pull requests and issues since 1.1 was released to see if there are other reports) a fix.

I don’t have the track and pinion, so I’m running from the base fork, I could see benefit in getting the updates pushed back into the base, there are a few pull requests from earlier in the year, but they were never committed.


#54

I wasn’t able to resolve the issue. I noticed that when it was able to successfully print, the initial height of nozzle was too high and the first layer was getting messed up. I decided to revert back to the original firmware on the machine since everything was working fine with it. Hopefully this issue will be resolved.


#55

i thought, lets take one for the team, and tried to compile and upload this edited marlin, using the gt2560 modified config, and it all complies and then wont upload, i am assuming i dont have the correct baud rate to upload, or there is some kind of lock on the board, can anyone shed light on this, i have the error log saved but i cant post it here for some reason


#56

I’m running 1.1.x straight from the marlin fork. The last few changes I have done, I have found inconsistent results re memory and settings, it seems to set some to the values in firmware and others to eeprom - so that could be your nozzle height problem.


#57

I did another rebase of the Wilson changes over the Marlin 1.1.x branch, which is now at version 1.1.3 and haven’t noticed any problems. In fact, my prints have improved. The only changes I put in specifically for my machine after the Wilson defaults, meaning these changes are never committed to my Wilson fork, are to set the bedleveling to bilinear with subdivision, set the probe offset and increase the extruder maxtemp for the E3D-V6. Everything else is matched to as close as possible to Marty’s original settings from the older Marlin fork.


#58

@Sieneskil Sorry, missed your reply. Take a look at Rockey’s post for instructions on uploading the firmware: http://community.reprapwilson3d.com/t/setup-usb-connection-resolved/891/8


#59

Is the RCBugFix-mjrice from the mjrice/Marlin now the standard Wilson II firmware? I mean, is it considered to be ready for everyday use?

Thanks!


#60

So if we want to upgrade to the new Marlin 1.1.x, do we download RCBugFix-mjrice OR the one from Robbforce?