X and Y axis only move in the positive direction [SOLVED]


I recently just did some modifications to my Wilson II build all of which have been physical changes. After re-assembling and plugging all the wires back in, I tried moving each axis manually to ensure they were going the correct direction. When I turn knob to increase the X-axis value it moves just fine but when I turn the knob back to make it go in the negative X-direction it doesn’t move. The Y-axis does the same thing but both Z-axes move positive and negative just fine.
When it is moving in X+ or Y+ it sounds fine but when I try to go X- or Y- the motor makes a slight clicking sound. I tried adjusting the current on the drivers and it didn’t change anything. I’m including a video to show you what it looks and sounds like.
Any help would be appreciated.


Ok… moving positive in X would be to the right not left… so reverse that cable.

Check X and Y motor wire plugs sometimes the connection is loose in the plug.

Did you rewire or lengthen the X or Y motor wires? maybe 2 of the 4 wires is wrong or a broken wire maybe.

… otherwise endstop wires are either not connected properly or broken possibly.

All I can think of.


I got it. Turns out I had the X and Y endstops plugged into the spots that say X MAX and Y MAX. They have to be plugged into to X MIN and Y MIN. Seems wrong, but that’s what it was.