Z-axis not working


This is my first step in 3d printing.
I can’t have the Z-axis working, when the motors are free they turn properly (and in the same direction), but when I connect the couplers to the lead screws (I’ve got some similar to these ones with 1mm pitch) and try to move the Z-axis the motor are just vibrating and nothing move. I guess there is too much friction for the motors, despite I can turn them by hand without much effort.

I tried to increase the current by turning the screw on the stepper driver (but it can turn indefinitely so I don’t know when it is right, I try a bit further than with the neutral position).

Do you have any advice to help me solve this issue?

Thank you.


Check out the section on tuning current here: http://reprap.org/wiki/Pololu_stepper_driver_board


Thanks. I don’t know what really to get from this link, but I tuned the driver to measure the maximum voltage.
I managed to fix the issue with some lubricant and by moving a bit one of the motor.

I still have an issue; using pronterface I can move the Z-axis from top to bottom with the manual move button but when I press the home button, the motors vibrate and nothing happen.
On other axis, I also got the motors vibrating when homing but after they move to hit the endstop.


Does your printer sound like this

If it does I would love to know how you solved this. This is also my first printer.


Not really, my sound was at much higher frequency.

I solved it by lowering the moving speed on Z axis in Marlin:

#define HOMING_FEEDRATE_Z (4*60)

I changed it to 3*60 and now it works fine.


Your steppers are skipping steps. You should turn up your stepper driver current, using the guide Squid linked earlier.


Yes, I read it but it is still really blurry. I can’t see how it applies here.

They say that you can set your target current by adjusting the screw and read the potential. So far so good but:

  • I don’t know the resistance of my steppers as they say Chinese ones can vary from 0.05 ohm to 0.1 ohm, so it doubles the potential you should read, so you adjust a setting with a potential 100% error, … meeeeh (maybe I can measure the resistance somewhere but it is not said in the guide)
  • 2nd point and more disturbing one. What is my target current? The guide gives an example by setting 70% of maximum rated current to limit heat. Ok, but I just want my motor to turn properly, I will care about temperature later. So, what is my target current?

In practical I tuned the screw to get the maximum potential possible, leading to maximum current and it worked, but it is not satisfying.


Yeah that might cook something!! If they are generic ebay/aliexpress motors id guess they are 1.2A I searched my ebay orders and found the spec sheet - due to complete lack of markings on the motor.

Not sure why you want imdpedance of the stepper - thats not really relevant/useful, just measure vref while it is on and tune until you get the right value.


That’s the thing “the right value”, what is it?
It is where I found the wiki page dumb, it seems just arbitrary.


Assuming you are running 4988s and you stepper motors are 1.2a then vref will be:
1.28.05 = 0.48

Some say you should factor in a safety margin and use 1 instead of 1.2. I havent found overheating to be an issue so I have left it at 1.2.